wordpress安装插件get_loaded_extensions已被禁用

作者: 鲁智深 分类: wordpress 发布时间: 2014-10-27 00:50

在测试oss-support-master插件时出现如下报错,如果是虚拟主机的话一般不是出现如下问题,空间商早就已经解决了!自己配置的ECS服务器那就是看这我的这篇教程,赶紧修改吧!

报错内容如下

插件报错

插件报错

翻译后:

致命错误:未捕获的异常’OSS_Exception“有消息”功能get_loaded_extensions已被禁用,请检查PHP配置“。

也就是说服务器PHP配置文件禁止了get_loaded_extensions函数的使用,问题找的了,开始解决!

在服务器找的php.ini文件,并且打开php.ini,命令:

vi /路径/php.ini

查找 disable_functions,可以看到disable_functions=‘……’一堆的函数。disable_functions=”后面的这些函数是为了服务器安全默认禁止的,需要解除禁止的函数直接删除,然后保存就可以了。

禁用功能

禁用功能

在找的get_loaded_extensions函数,把它删除,保存。

重启服务器,在安装一下插件即可!

如果觉得我的文章对您有用,请随意打赏。您的支持将鼓励我继续创作!

发表评论

电子邮件地址不会被公开。 必填项已用*标注